Avaire Forum  
  #1  
Old 06-22-2009, 07:19 PM
Avaire Archive Avaire Archive is offline
Archive
 
Join Date: Jun 2009
Posts: 943
Default subfloor prep

Author: Larry
Date: 4/22/2008 7:51 pm EDT
Ok, the local store had some avaire tile on sale so I went and picked up enough to do my kitchen and dining area.

I had parquet wood squares down and didnt want to lay the avaire tile over the top due to height concerns and the chance that I may need to remove my dish washer.

So I began by pulling up all the old parquet, it didnt come up too hard but the adhesive used was a little rough on the plywood underlayment in spots.

I began so sand off excess adhesive and hit visibly high spots with a belt sander when things came to a screeching halt when I got into the dining room where another type of adhesive must have been used. It just gummed up the belt after a few seconds so it was off to plan B, a heat gun and a putty knife. 10+ hours later I finally got the glue up.

I slid a single tile around the room checking to see if it would teeter and for the most part all seemed fine. I hit a couple more evident high spots with a belt sander and filled some low spots with a skim coat. I then snapped a few tiles together to plan my layout and then began sliding this small bunch around and in area that were previously fine there seemed to be some rise and fall as I pressed down on various areas of the small batch of tiles.

Not wanting to risk breaking any tiles I figured that was too much movement.

Headed to the local store and picked up some pails of concrete based self leveling underlayment. Supposedly easy flowing and self leveling. Since none of my low spots/high spots seemed very extreme over any distance, with gauging rake in hand (set to less than 1/8") I began to pour my mixed self leveling underlayment. I used the exact amount of water recommended and while the stuff did flow, it didnt flow anywhere near as easy as I expected. Thinking it was easy flowing I didnt bother with a smoothing blade thinking it would all just flow and even out.

Fast forward to the next day, what a mess. The floor is now less even than when I started, the self leveling underlayment wasnt so self leveling and is bonded to the subfloor nice and tight.

The manufacturer recommended I simply add another coat but I simply cant see spending the money to add more height (which im trying to avoid) just to have a still uneven floor.

So, whats the point of my post? Well, there is no doubt that the actual avaire tile installation is easier that standard tile but as things sit for me now it would have a heck of a lot easier for me just to lay down standard tile.

I for one would really like to know how everyone is getting their subfloor flat enough to lay avaire tile or am I just being too critical?

Now I am left going over my *cough* self leveling *cough* underlayment with more skim coat in an effort to level things out and prevent any teetering but it seems everytime I get one teeter fixed another pops us..
Reply With Quote
  #2  
Old 06-22-2009, 07:20 PM
Avaire Archive Avaire Archive is offline
Archive
 
Join Date: Jun 2009
Posts: 943
Default

Author: Journeyman
Date: 4/23/2008 7:29 pm EDT
Hi Larry,

The industry standard for a flat subfloor when installing traditional ceramic tile is to have not more than 1/4" variance in 10 feet. Avaire tile works fine if installed over a subfloor meeting that criteria.

Did you use the recommended primer for the Self Levelling Compound? The primer seals the substrate and aids the flow of the self leveller and is a must.

If you choose not to add more leveller as already suggested then your next best-bet is to rent a (17") floor-machine and buy some sanding discs. The discs will grind the surface and once you get the hang of it you will be able to feel the highs and the lows and figure out the process.

Traditional ceramic wouldn't be any easier or any better than the Avaire tile at this point.
Reply With Quote
  #3  
Old 06-22-2009, 07:21 PM
Avaire Archive Avaire Archive is offline
Archive
 
Join Date: Jun 2009
Posts: 943
Default

Author: Larry
Date: 4/25/2008 4:56 pm EDT
Yes, I primed the floor first. I tried busting it up in one spot and its bonded quite nicely to the floor.

I dont think there is any more than a 1/4" varyance in 10'. However, there are a lot of spots where tiles teeter due to a "ridge" or "bump" if you will.
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 04:19 AM.


Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.

(888) 528-2473 Copyright © 2009 : CoMc, LLC All Rights Reserved. ~ Design by Chip Thompson