Avaire Forum  
  #1  
Old 08-22-2010, 10:56 AM
Sherry Sherry is offline
Junior Member
 
Join Date: Aug 2010
Posts: 1
Default Help

My mom just had these tiles professional installed in her home. There is some sort of glue or grout or something that is left on top of the tile. You can see residue from something that has left an imprint of the word Avaire on some of the tile and on other you can see an imprint of the web looking plastic from the back of another tile. Has this happened to others? What would cause this? and how can it be fixed? If it would help I may be able to take a photo to attach. Just don't know if it will show up. Thanks!
Reply With Quote
  #2  
Old 08-24-2010, 12:55 PM
Chris Chris is offline
Junior Member
 
Join Date: Oct 2009
Posts: 19
Default Help

Sherry,

I have this happen to me quite often. It's from not cleaning the grout residue off the tile good enough. When there's some grout haze left on the tile the grind from the back of the tray shows in certain light, I haven't seen the word Avaire on the tile yet.

If you used the acrylic grout then have the installers use acetone to clean the grout haze, if urethane grout use Krud Kutter. Both are available at most home centers.

Let me know how it goes.
Chris.
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 12:27 PM.


Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.

(888) 528-2473 Copyright © 2009 : CoMc, LLC All Rights Reserved. ~ Design by Chip Thompson